Tech Support

Okay . . . let's try this again.

Moderators: Shirley, brian, ZMan, Sabo

User avatar
brian
The Dude
Posts: 21051
Joined: Mon Mar 18, 2013 10:52 am
Location: Home, watching the NHL Playoffs

Re: Tech Support

Post by brian » Wed Jul 29, 2020 5:50 pm

If you're feeling nostalgic for the 90s a developer turned a MacOS 8.1 system into an app that can be installed on Windows, Mac or Linux and includes playable versions of some 90s era games.
Image

User avatar
Sabo
Walter Sobchak
Posts: 4839
Joined: Mon Mar 11, 2013 8:33 am
Location: On the trail

Re: Tech Support

Post by Sabo » Wed Jul 29, 2020 6:15 pm

brian wrote:
Wed Jul 29, 2020 5:50 pm
If you're feeling nostalgic for the 90s a developer turned a MacOS 8.1 system into an app that can be installed on Windows, Mac or Linux and includes playable versions of some 90s era games.
Hail to the king, baby.
Mallards rule.

So do cassowaries.

User avatar
DaveInSeattle
Walter Sobchak
Posts: 4563
Joined: Mon Mar 18, 2013 5:51 am
Location: Seattle, WA

Re: Tech Support

Post by DaveInSeattle » Wed Aug 05, 2020 7:40 pm

Any C# people here? (I think Shirley does C#, but don't remember)

Anyways, here's my issue: Our instruments allow for doing remote archiving, using SSH. But sometimes our users set up the remote disc with a password that has a non-standard character in it (something like a '$' or '!' seems to trigger it). So I need to make to make it so that we 'escape' those wonky characters.

I initially put a regexp bit in the javascript code, but then was told 'No...we want to do that as close to the ssh call in the server side as possible'. So then I started to hunt around for how to do it in C#, but of course there's not a similar function (at least that I can find).

In scanning StackOverflow, I found this:

Code: Select all

 // Used to escape any non-standard characters that might be found in the remote archive password
        private static string ToLiteral(string input)
        {
            using (var writer = new StringWriter())
            {
                using (var provider = CodeDomProvider.CreateProvider("CSharp"))
                {
                    provider.GenerateCodeFromExpression(new CodePrimitiveExpression(input), writer, null);
                    return writer.ToString();
                }
            }
        }
But I'm not sure if that's really the best way to handle it. I do know, from reading the defect ticket, that the work-around is putting the password, when entered on the instrument, in single quotes.

Any help would be appreciated!

User avatar
Shirley
The Dude
Posts: 5509
Joined: Mon Mar 11, 2013 2:32 pm

Re: Tech Support

Post by Shirley » Thu Aug 06, 2020 10:54 am

1. Every password should include some punctuation characters, so that should be expected.
2. I'm not really clear on what your problem is. Where are these characters causing you problems?
3. Escaping off the characters is a pretty standard technique to protect "special" characters in strings. I don't know those C# libraries being used, but it generally looks correct. If it got good reviews in Stack Overflow, it's probably a safe bet.
4. Make sure you aren't storing these passwords in any sort of plaintext file, even if you escaped them first.
Totally Kafkaesque

User avatar
DaveInSeattle
Walter Sobchak
Posts: 4563
Joined: Mon Mar 18, 2013 5:51 am
Location: Seattle, WA

Re: Tech Support

Post by DaveInSeattle » Thu Aug 06, 2020 11:11 am

Shirley wrote:
Thu Aug 06, 2020 10:54 am
1. Every password should include some punctuation characters, so that should be expected.
2. I'm not really clear on what your problem is. Where are these characters causing you problems?
3. Escaping off the characters is a pretty standard technique to protect "special" characters in strings. I don't know those C# libraries being used, but it generally looks correct. If it got good reviews in Stack Overflow, it's probably a safe bet.
4. Make sure you aren't storing these passwords in any sort of plaintext file, even if you escaped them first.
1. Yeah, but for some reason the ! and @ breaks things. Why? Who knows...
2. The users set up a shared disk on a remote computer with a password. The issue is when they try to enter that password on our Instrument.
3. I ran it past our C# guru, and he thought it looked ok as well. I'm still a C# neophyte, so when things start calling all kinds of strange libs I get nervous.
4. Yeah, that was my problem, at first. I wanted to escape the characters on the Client side (when the user enters the password) which would have meant the 'escaped' password would have been encrpyted and saved in the system. I was told that was frowned upon.

Thanks for the feedback!

User avatar
Steve of phpBB
Walter Sobchak
Posts: 4514
Joined: Mon Mar 11, 2013 10:44 am

Re: Tech Support

Post by Steve of phpBB » Thu Aug 06, 2020 1:18 pm

Okay ... so what is the easiest way to post a photograph from my iPhone onto the Swamp?
And his one problem is he didn’t go to Russia that night because he had extracurricular activities, and they froze to death.

User avatar
rass
The Dude
Posts: 13657
Joined: Mon Mar 18, 2013 9:41 am
Location: N effin' J

Re: Tech Support

Post by rass » Thu Aug 06, 2020 1:36 pm

See the Attachments tab/button down there when posting?
I felt aswirl with warm secretions.

User avatar
A_B
The Dude
Posts: 15857
Joined: Mon Mar 11, 2013 7:36 am
Location: Getting them boards like a wolf in the chicken pen.

Re: Tech Support

Post by A_B » Thu Aug 06, 2020 2:15 pm

3FE59CB4-2521-4510-9C78-BBBB8FD1E807.jpeg
3FE59CB4-2521-4510-9C78-BBBB8FD1E807.jpeg (23.81 KiB) Viewed 263 times
WHO THE HELL KNEW?!?!?
The wife just accidentally called you. “Accidentally”. Sorry

User avatar
rass
The Dude
Posts: 13657
Joined: Mon Mar 18, 2013 9:41 am
Location: N effin' J

Re: Tech Support

Post by rass » Thu Aug 06, 2020 2:26 pm

Technically correct or not... FIFY
A_B wrote:
Thu Aug 06, 2020 2:15 pm
WHO THE HELL NEWT?!?!?
I felt aswirl with warm secretions.

User avatar
Steve of phpBB
Walter Sobchak
Posts: 4514
Joined: Mon Mar 11, 2013 10:44 am

Re: Tech Support

Post by Steve of phpBB » Thu Aug 06, 2020 2:55 pm

Hm. I do see that button. (How long has that been there?)

But when I try it, I get a "file too large" error message.

(Even when I'm doing it with a screen cap that's 271 KB.)
And his one problem is he didn’t go to Russia that night because he had extracurricular activities, and they froze to death.

User avatar
DaveInSeattle
Walter Sobchak
Posts: 4563
Joined: Mon Mar 18, 2013 5:51 am
Location: Seattle, WA

Re: Tech Support

Post by DaveInSeattle » Thu Aug 06, 2020 7:47 pm

Shirley wrote:
Thu Aug 06, 2020 10:54 am
1. Every password should include some punctuation characters, so that should be expected.
2. I'm not really clear on what your problem is. Where are these characters causing you problems?
3. Escaping off the characters is a pretty standard technique to protect "special" characters in strings. I don't know those C# libraries being used, but it generally looks correct. If it got good reviews in Stack Overflow, it's probably a safe bet.
4. Make sure you aren't storing these passwords in any sort of plaintext file, even if you escaped them first.
Well...that didn't work. The $ character, in the middle of a password, didn't work.

Grrr...

User avatar
DaveInSeattle
Walter Sobchak
Posts: 4563
Joined: Mon Mar 18, 2013 5:51 am
Location: Seattle, WA

Re: Tech Support

Post by DaveInSeattle » Thu Aug 06, 2020 11:47 pm

DaveInSeattle wrote:
Thu Aug 06, 2020 7:47 pm
Shirley wrote:
Thu Aug 06, 2020 10:54 am
1. Every password should include some punctuation characters, so that should be expected.
2. I'm not really clear on what your problem is. Where are these characters causing you problems?
3. Escaping off the characters is a pretty standard technique to protect "special" characters in strings. I don't know those C# libraries being used, but it generally looks correct. If it got good reviews in Stack Overflow, it's probably a safe bet.
4. Make sure you aren't storing these passwords in any sort of plaintext file, even if you escaped them first.
Well...that didn't work. The $ character, in the middle of a password, didn't work.

Grrr...
Since I posted the original question, here's what the answer was:
3.1.2.2 Single Quotes

Enclosing characters in single quotes (') preserves the literal value of each character within the quotes. A single quote may not occur between single quotes, even when preceded by a backslash.

3.1.2.3 Double Quotes

Enclosing characters in double quotes (") preserves the literal value of all characters within the quotes, with the exception of $, `, \, and, when history expansion is enabled, !. The characters $ and ` retain their special meaning within double quotes (see Shell Expansions). The backslash retains its special meaning only when followed by one of the following characters: $, `, ", \, or newline. Within double quotes, backslashes that are followed by one of these characters are removed. Backslashes preceding characters without a special meaning are left unmodified. A double quote may be quoted within double quotes by preceding it with a backslash. If enabled, history expansion will be performed unless an ! appearing in double quotes is escaped using a backslash. The backslash preceding the ! is not removed.

The special parameters * and @ have special meaning when in double quotes (see Shell Parameter Expansion).
So the issue wasn't with how c# escapes characters, it was how SSH handles the special characters. Gah...

User avatar
rass
The Dude
Posts: 13657
Joined: Mon Mar 18, 2013 9:41 am
Location: N effin' J

Re: Tech Support

Post by rass » Fri Aug 07, 2020 7:17 am

Steve of phpBB wrote:
Thu Aug 06, 2020 2:55 pm
Hm. I do see that button. (How long has that been there?)

But when I try it, I get a "file too large" error message.

(Even when I'm doing it with a screen cap that's 271 KB.)
I think I have had to resize photos when posting from my phone...
I felt aswirl with warm secretions.

User avatar
DaveInSeattle
Walter Sobchak
Posts: 4563
Joined: Mon Mar 18, 2013 5:51 am
Location: Seattle, WA

Re: Tech Support

Post by DaveInSeattle » Fri Aug 07, 2020 6:51 pm

DaveInSeattle wrote:
Thu Aug 06, 2020 7:47 pm
Shirley wrote:
Thu Aug 06, 2020 10:54 am
1. Every password should include some punctuation characters, so that should be expected.
2. I'm not really clear on what your problem is. Where are these characters causing you problems?
3. Escaping off the characters is a pretty standard technique to protect "special" characters in strings. I don't know those C# libraries being used, but it generally looks correct. If it got good reviews in Stack Overflow, it's probably a safe bet.
4. Make sure you aren't storing these passwords in any sort of plaintext file, even if you escaped them first.
Well...that didn't work. The $ character, in the middle of a password, didn't work.

Grrr...
And now I've got it to working with all of the special characters...with the exception of a double quote...or a comma. Even when escaping those, the password field in the SSH command breaks.

If we weren't in the middle of a global pandemic..and an economic meltdown...and with a kid in private school...i would just fucking quit. That frustrated.

User avatar
Shirley
The Dude
Posts: 5509
Joined: Mon Mar 11, 2013 2:32 pm

Re: Tech Support

Post by Shirley » Sat Aug 08, 2020 8:54 am

DaveInSeattle wrote:
Fri Aug 07, 2020 6:51 pm
DaveInSeattle wrote:
Thu Aug 06, 2020 7:47 pm
Shirley wrote:
Thu Aug 06, 2020 10:54 am
1. Every password should include some punctuation characters, so that should be expected.
2. I'm not really clear on what your problem is. Where are these characters causing you problems?
3. Escaping off the characters is a pretty standard technique to protect "special" characters in strings. I don't know those C# libraries being used, but it generally looks correct. If it got good reviews in Stack Overflow, it's probably a safe bet.
4. Make sure you aren't storing these passwords in any sort of plaintext file, even if you escaped them first.
Well...that didn't work. The $ character, in the middle of a password, didn't work.

Grrr...
And now I've got it to working with all of the special characters...with the exception of a double quote...or a comma. Even when escaping those, the password field in the SSH command breaks.

If we weren't in the middle of a global pandemic..and an economic meltdown...and with a kid in private school...i would just fucking quit. That frustrated.
A common handling of a double quote within a double-quoted string is to use two consecutive double quotes, a quadruple quote, if you will. Not sure about the comma. Another common way to protect characters like that is to just put a slash, \, in front of them.

So if your password is Hey"do,od
You'd turn it into this - "Hey""do\,od"
Or maybe - "Hey\"do\,od"

Try those
Totally Kafkaesque

User avatar
DaveInSeattle
Walter Sobchak
Posts: 4563
Joined: Mon Mar 18, 2013 5:51 am
Location: Seattle, WA

Re: Tech Support

Post by DaveInSeattle » Sat Aug 08, 2020 9:52 am

Shirley wrote:
Sat Aug 08, 2020 8:54 am
DaveInSeattle wrote:
Fri Aug 07, 2020 6:51 pm
DaveInSeattle wrote:
Thu Aug 06, 2020 7:47 pm
Shirley wrote:
Thu Aug 06, 2020 10:54 am
1. Every password should include some punctuation characters, so that should be expected.
2. I'm not really clear on what your problem is. Where are these characters causing you problems?
3. Escaping off the characters is a pretty standard technique to protect "special" characters in strings. I don't know those C# libraries being used, but it generally looks correct. If it got good reviews in Stack Overflow, it's probably a safe bet.
4. Make sure you aren't storing these passwords in any sort of plaintext file, even if you escaped them first.
Well...that didn't work. The $ character, in the middle of a password, didn't work.

Grrr...
And now I've got it to working with all of the special characters...with the exception of a double quote...or a comma. Even when escaping those, the password field in the SSH command breaks.

If we weren't in the middle of a global pandemic..and an economic meltdown...and with a kid in private school...i would just fucking quit. That frustrated.
A common handling of a double quote within a double-quoted string is to use two consecutive double quotes, a quadruple quote, if you will. Not sure about the comma. Another common way to protect characters like that is to just put a slash, \, in front of them.

So if your password is Hey"do,od
You'd turn it into this - "Hey""do\,od"
Or maybe - "Hey\"do\,od"

Try those
Its not the password per se that the issue...its putting the password (with the escape characters included) in the string that makes up the SSH command that gets sent out, where it breaks.

User avatar
DaveInSeattle
Walter Sobchak
Posts: 4563
Joined: Mon Mar 18, 2013 5:51 am
Location: Seattle, WA

Re: Tech Support

Post by DaveInSeattle » Sat Aug 08, 2020 10:32 am

Shirley wrote:
Sat Aug 08, 2020 8:54 am
DaveInSeattle wrote:
Fri Aug 07, 2020 6:51 pm
DaveInSeattle wrote:
Thu Aug 06, 2020 7:47 pm
Shirley wrote:
Thu Aug 06, 2020 10:54 am
1. Every password should include some punctuation characters, so that should be expected.
2. I'm not really clear on what your problem is. Where are these characters causing you problems?
3. Escaping off the characters is a pretty standard technique to protect "special" characters in strings. I don't know those C# libraries being used, but it generally looks correct. If it got good reviews in Stack Overflow, it's probably a safe bet.
4. Make sure you aren't storing these passwords in any sort of plaintext file, even if you escaped them first.
Well...that didn't work. The $ character, in the middle of a password, didn't work.

Grrr...
And now I've got it to working with all of the special characters...with the exception of a double quote...or a comma. Even when escaping those, the password field in the SSH command breaks.

If we weren't in the middle of a global pandemic..and an economic meltdown...and with a kid in private school...i would just fucking quit. That frustrated.
A common handling of a double quote within a double-quoted string is to use two consecutive double quotes, a quadruple quote, if you will. Not sure about the comma. Another common way to protect characters like that is to just put a slash, \, in front of them.

So if your password is Hey"do,od
You'd turn it into this - "Hey""do\,od"
Or maybe - "Hey\"do\,od"

Try those
And, just like that....I think your post sparked a brainstorm. I think that you have to escape the backslash as well...so if the password is Hey"do,od its needs to be Hey\\\"do\\\,od

Gonna go try it in a few minutes....but I really think that might be it.

User avatar
Shirley
The Dude
Posts: 5509
Joined: Mon Mar 11, 2013 2:32 pm

Re: Tech Support

Post by Shirley » Sat Aug 08, 2020 11:17 am

Yeah, I was going to suggest something like that. Often, in these cases, your string is actually getting interpreted twice - once by C# and again by SSH. So, you do need to double slash things to make them work.
Totally Kafkaesque

User avatar
DaveInSeattle
Walter Sobchak
Posts: 4563
Joined: Mon Mar 18, 2013 5:51 am
Location: Seattle, WA

Re: Tech Support

Post by DaveInSeattle » Sat Aug 08, 2020 6:43 pm

Shirley wrote:
Sat Aug 08, 2020 11:17 am
Yeah, I was going to suggest something like that. Often, in these cases, your string is actually getting interpreted twice - once by C# and again by SSH. So, you do need to double slash things to make them work.
Didn't work...I'm definitely falling back to the 'Tell the Users don't be a dumb ass by putting a double quote or a comma in their password". Well...and putting a question up on StackOverflow.

User avatar
Giff
The Dude
Posts: 6244
Joined: Mon Mar 25, 2013 3:26 pm

Re: Tech Support

Post by Giff » Mon Aug 10, 2020 12:12 pm

Is there a way to turn off auto-capitalizing the next word you type after pasting something in Outlook?
Muh.

User avatar
wlu_lax6
The Dude
Posts: 7183
Joined: Tue Mar 12, 2013 7:16 am

Re: Tech Support

Post by wlu_lax6 » Mon Aug 10, 2020 1:27 pm

Giff wrote:
Mon Aug 10, 2020 12:12 pm
Is there a way to turn off auto-capitalizing the next word you type after pasting something in Outlook?
I think you are hitting autocorrect to start a sentence. You can turn this off. Best way to do so is hit the ghost button (start a new email and type "the" -leave the quotes out). Take your mouse and go back over the capitalized item. A button shows up right below the thing that corrected. Click on that. You will see a stop auto correcting for this scenario option.

Best use of the ghost button is quick fixes for paste (i.e. you paste and you want it to be a paste plain text or other paste special behavior).

Fun side note...I am the inventor of that ghost button feature.....Did not get credit for it as it was not my area but I basically gave that idea to the person who did all the hard work making it happen.

duff
The Big Lebowski
Posts: 1900
Joined: Mon Apr 01, 2013 3:36 pm

Re: Tech Support

Post by duff » Mon Aug 10, 2020 1:57 pm

wlu_lax6 wrote:
Mon Aug 10, 2020 1:27 pm
Giff wrote:
Mon Aug 10, 2020 12:12 pm
Is there a way to turn off auto-capitalizing the next word you type after pasting something in Outlook?
I think you are hitting autocorrect to start a sentence. You can turn this off. Best way to do so is hit the ghost button (start a new email and type "the" -leave the quotes out). Take your mouse and go back over the capitalized item. A button shows up right below the thing that corrected. Click on that. You will see a stop auto correcting for this scenario option.

Best use of the ghost button is quick fixes for paste (i.e. you paste and you want it to be a paste plain text or other paste special behavior).

Fun side note...I am the inventor of that ghost button feature.....Did not get credit for it as it was not my area but I basically gave that idea to the person who did all the hard work making it happen.
And Al Gore created the internet. Congrats.
To quote both Bruce Prichard and Tony Schiavone, "Fuck Duff Meltzer."

User avatar
mister d
The Dude
Posts: 19096
Joined: Tue Mar 12, 2013 8:15 am

Re: Tech Support

Post by mister d » Mon Aug 10, 2020 2:11 pm

The Al Groe of the swamp.
rass wrote:
Mon Apr 20, 2020 11:20 am
I'm definitely known as "the boy who cried penis" in town.

User avatar
Giff
The Dude
Posts: 6244
Joined: Mon Mar 25, 2013 3:26 pm

Re: Tech Support

Post by Giff » Mon Aug 10, 2020 4:39 pm

wlu_lax6 wrote:
Mon Aug 10, 2020 1:27 pm
Giff wrote:
Mon Aug 10, 2020 12:12 pm
Is there a way to turn off auto-capitalizing the next word you type after pasting something in Outlook?
I think you are hitting autocorrect to start a sentence. You can turn this off. Best way to do so is hit the ghost button (start a new email and type "the" -leave the quotes out). Take your mouse and go back over the capitalized item. A button shows up right below the thing that corrected. Click on that. You will see a stop auto correcting for this scenario option.

Best use of the ghost button is quick fixes for paste (i.e. you paste and you want it to be a paste plain text or other paste special behavior).

Fun side note...I am the inventor of that ghost button feature.....Did not get credit for it as it was not my area but I basically gave that idea to the person who did all the hard work making it happen.
This worked, but it's stupid i have to because it's very rare that I paste something into a sentence that ends up being the last word of a sentence. There's not even a period when this happens.
Muh.

User avatar
wlu_lax6
The Dude
Posts: 7183
Joined: Tue Mar 12, 2013 7:16 am

Re: Tech Support

Post by wlu_lax6 » Mon Aug 10, 2020 8:06 pm

Giff wrote:
Mon Aug 10, 2020 4:39 pm
wlu_lax6 wrote:
Mon Aug 10, 2020 1:27 pm
Giff wrote:
Mon Aug 10, 2020 12:12 pm
Is there a way to turn off auto-capitalizing the next word you type after pasting something in Outlook?
I think you are hitting autocorrect to start a sentence. You can turn this off. Best way to do so is hit the ghost button (start a new email and type "the" -leave the quotes out). Take your mouse and go back over the capitalized item. A button shows up right below the thing that corrected. Click on that. You will see a stop auto correcting for this scenario option.

Best use of the ghost button is quick fixes for paste (i.e. you paste and you want it to be a paste plain text or other paste special behavior).

Fun side note...I am the inventor of that ghost button feature.....Did not get credit for it as it was not my area but I basically gave that idea to the person who did all the hard work making it happen.
This worked, but it's stupid i have to because it's very rare that I paste something into a sentence that ends up being the last word of a sentence. There's not even a period when this happens.
Yeah, this actually makes way more sense when you understand how Word stores formatting at the letter, sentence, and paragraph levels. If you are old Word Perfect person you think, oh it is like Reveal codes (dating myself) or HTML with a block around it. However word does not store formatting that way. Once you understand that formatting is often on the paragraph mark it makes dealing with bullets and tables way more understandable.

You know another option maybe to use the paste special as text. This way you don't bring the formatting over. You can also access the ghost button after pasting (that was the actual genesis of the feature) to bring up paste special.
Last edited by wlu_lax6 on Mon Aug 10, 2020 8:09 pm, edited 1 time in total.

User avatar
wlu_lax6
The Dude
Posts: 7183
Joined: Tue Mar 12, 2013 7:16 am

Re: Tech Support

Post by wlu_lax6 » Mon Aug 10, 2020 8:08 pm

duff wrote:
Mon Aug 10, 2020 1:57 pm
wlu_lax6 wrote:
Mon Aug 10, 2020 1:27 pm
Giff wrote:
Mon Aug 10, 2020 12:12 pm
Is there a way to turn off auto-capitalizing the next word you type after pasting something in Outlook?
I think you are hitting autocorrect to start a sentence. You can turn this off. Best way to do so is hit the ghost button (start a new email and type "the" -leave the quotes out). Take your mouse and go back over the capitalized item. A button shows up right below the thing that corrected. Click on that. You will see a stop auto correcting for this scenario option.

Best use of the ghost button is quick fixes for paste (i.e. you paste and you want it to be a paste plain text or other paste special behavior).

Fun side note...I am the inventor of that ghost button feature.....Did not get credit for it as it was not my area but I basically gave that idea to the person who did all the hard work making it happen.
And Al Gore created the internet. Congrats.
May not have gotten credit for that one...but did on this one....
https://patents.google.com/patent/US742 ... &oq=egorin

which was subsequently removed from the product several versions later because nobody used it

User avatar
Steve of phpBB
Walter Sobchak
Posts: 4514
Joined: Mon Mar 11, 2013 10:44 am

Re: Tech Support

Post by Steve of phpBB » Mon Aug 10, 2020 9:56 pm

wlu_lax6 wrote:
Mon Aug 10, 2020 8:08 pm
duff wrote:
Mon Aug 10, 2020 1:57 pm
wlu_lax6 wrote:
Mon Aug 10, 2020 1:27 pm
Giff wrote:
Mon Aug 10, 2020 12:12 pm
Is there a way to turn off auto-capitalizing the next word you type after pasting something in Outlook?
I think you are hitting autocorrect to start a sentence. You can turn this off. Best way to do so is hit the ghost button (start a new email and type "the" -leave the quotes out). Take your mouse and go back over the capitalized item. A button shows up right below the thing that corrected. Click on that. You will see a stop auto correcting for this scenario option.

Best use of the ghost button is quick fixes for paste (i.e. you paste and you want it to be a paste plain text or other paste special behavior).

Fun side note...I am the inventor of that ghost button feature.....Did not get credit for it as it was not my area but I basically gave that idea to the person who did all the hard work making it happen.
And Al Gore created the internet. Congrats.
May not have gotten credit for that one...but did on this one....
https://patents.google.com/patent/US742 ... &oq=egorin

which was subsequently removed from the product several versions later because nobody used it
1. That’s pretty awesome.

2. Just seeing the phrase “Reveal Codes” makes me bitter all over again that Word beat out WordPerfect. After twenty-plus years of using Word I still have no idea how to control the formatting. I’ll cut and paste something in Times New Roman, plug it into a different paragraph in Times New Roman, and it’ll change itself to Calibri.

3. What’s a “ghost button”?

2. What’s the Ghost Button?
And his one problem is he didn’t go to Russia that night because he had extracurricular activities, and they froze to death.

User avatar
wlu_lax6
The Dude
Posts: 7183
Joined: Tue Mar 12, 2013 7:16 am

Re: Tech Support

Post by wlu_lax6 » Tue Aug 11, 2020 6:59 am

Steve of phpBB wrote:
Mon Aug 10, 2020 9:56 pm
wlu_lax6 wrote:
Mon Aug 10, 2020 8:08 pm
duff wrote:
Mon Aug 10, 2020 1:57 pm
wlu_lax6 wrote:
Mon Aug 10, 2020 1:27 pm
Giff wrote:
Mon Aug 10, 2020 12:12 pm
Is there a way to turn off auto-capitalizing the next word you type after pasting something in Outlook?
I think you are hitting autocorrect to start a sentence. You can turn this off. Best way to do so is hit the ghost button (start a new email and type "the" -leave the quotes out). Take your mouse and go back over the capitalized item. A button shows up right below the thing that corrected. Click on that. You will see a stop auto correcting for this scenario option.

Best use of the ghost button is quick fixes for paste (i.e. you paste and you want it to be a paste plain text or other paste special behavior).

Fun side note...I am the inventor of that ghost button feature.....Did not get credit for it as it was not my area but I basically gave that idea to the person who did all the hard work making it happen.
And Al Gore created the internet. Congrats.
May not have gotten credit for that one...but did on this one....
https://patents.google.com/patent/US742 ... &oq=egorin

which was subsequently removed from the product several versions later because nobody used it
1. That’s pretty awesome.

2. Just seeing the phrase “Reveal Codes” makes me bitter all over again that Word beat out WordPerfect. After twenty-plus years of using Word I still have no idea how to control the formatting. I’ll cut and paste something in Times New Roman, plug it into a different paragraph in Times New Roman, and it’ll change itself to Calibri.

3. What’s a “ghost button”?

2. What’s the Ghost Button?
Go to Word...type in something that autocorrect or paste something into word. Take you mouse and move it over the light gray bar that shows where the auto correct triggered or at the end of what you pasted. When you mouse over a button shows up right there. That is the ghost button. It is a context sensitive control that brings options forward (example: paste special when you paste or stop auto correcting).

Called the Ghost button because it is slightly transparent until you put your mouse on it. I have memories of very fun comments from watching users who never knew that existed usability test that.

User avatar
wlu_lax6
The Dude
Posts: 7183
Joined: Tue Mar 12, 2013 7:16 am

Re: Tech Support

Post by wlu_lax6 » Tue Aug 11, 2020 7:04 am

Steve of phpBB wrote:
Mon Aug 10, 2020 9:56 pm
wlu_lax6 wrote:
Mon Aug 10, 2020 8:08 pm
duff wrote:
Mon Aug 10, 2020 1:57 pm
wlu_lax6 wrote:
Mon Aug 10, 2020 1:27 pm
Giff wrote:
Mon Aug 10, 2020 12:12 pm
Is there a way to turn off auto-capitalizing the next word you type after pasting something in Outlook?
I think you are hitting autocorrect to start a sentence. You can turn this off. Best way to do so is hit the ghost button (start a new email and type "the" -leave the quotes out). Take your mouse and go back over the capitalized item. A button shows up right below the thing that corrected. Click on that. You will see a stop auto correcting for this scenario option.

Best use of the ghost button is quick fixes for paste (i.e. you paste and you want it to be a paste plain text or other paste special behavior).

Fun side note...I am the inventor of that ghost button feature.....Did not get credit for it as it was not my area but I basically gave that idea to the person who did all the hard work making it happen.
And Al Gore created the internet. Congrats.
May not have gotten credit for that one...but did on this one....
https://patents.google.com/patent/US742 ... &oq=egorin

which was subsequently removed from the product several versions later because nobody used it
1. That’s pretty awesome.

2. Just seeing the phrase “Reveal Codes” makes me bitter all over again that Word beat out WordPerfect. After twenty-plus years of using Word I still have no idea how to control the formatting. I’ll cut and paste something in Times New Roman, plug it into a different paragraph in Times New Roman, and it’ll change itself to Calibri.

3. What’s a “ghost button”?

2. What’s the Ghost Button?
Steve--here is the Word trick. Normally formatting is applied to the Paragraph mark. So when you copy something, if you select the paragraph mark (which you can see if you hit that button that makes paragraph marks show up) or past over it you get certain behaviors like you describe. I have found that it is best to paste special as text (or use the ghost button). But even better than that, just don't fight it and use the the format painter to fix the craziness. Format painter is the brush with the copy/paste options. You select the format you like, hit the format painter, and then select what you want to match the format you just grabbed. Pro tip. If you double clip the format painter you can paint multiple things (i.e. select, double click format painter, select, select, select, and hit esc when you are doing format painting.)

Post Reply